Commit 15c47e65 authored by Carlos Remuzzi's avatar Carlos Remuzzi
Browse files

actualizando instalador con ubuntu 18.04

parent 696a884d
......@@ -3,6 +3,7 @@
WIFI_INTERFACE=$(cat /proc/net/wireless | perl -ne '/(\w+):/ && print $1')
AP_PSK=libreCast
USER_NAME=$(whoami)
OS_RELEASE_FILE=/etc/os-release
verificar_debian_deps() {
echo "Verificando dependencias ..."
......@@ -58,18 +59,38 @@ verificar_archlinux_deps() {
}
verificar_deps() {
if [ -e /etc/os-release ]; then
. /etc/os-release
dist=$ID
code="${VERSION_CODENAME-$VERSION_ID}"
case "${dist}-${code}" in
arch-)
if [ -e ${OS_RELEASE_FILE} ]; then
. ${OS_RELEASE_FILE}
echo "Se ha detectado la distro ${PRETTY_NAME} ..."
case "${ID}-${VERSION_ID}" in
arch-*)
verificar_archlinux_deps
;;
ubuntu-16.04)
ubuntu-18.04*)
verificar_debian_deps
;;
ubuntu-14.04)
ubuntu-17.10*)
verificar_debian_deps
;;
ubuntu-17.04*)
verificar_debian_deps
;;
ubuntu-16.10*)
verificar_debian_deps
;;
ubuntu-16.04*)
verificar_debian_deps
;;
ubuntu-15.10*)
verificar_debian_deps
;;
ubuntu-15.04*)
verificar_debian_deps
;;
ubuntu-14.10*)
verificar_debian_deps
;;
ubuntu-14.04*)
verificar_debian_deps
;;
debian-9)
......@@ -79,7 +100,8 @@ verificar_deps() {
verificar_debian_deps
;;
*)
echo "ERROR: La distro \"$PRETTY_NAME\" no esta suportada" >&2
echo "ERROR: La distro ${PRETTY_NAME} no esta suportada" >&2
# Aqui se deberia poder guiar el usuario hacia una instalacion manual
exit 1
;;
esac
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment